ApproveENJ error 404


When trying to approve my wallet allowance I get the following error:

“message”: “No records found for Model: EnjinCoin\EnjinOauthClient”,
“code”: 404

I am logged into the Enjin site, my wallet daemon is running and I substituted my identity_id into identity_id field of the mutation script.

What is the problem here? I get the same issue trying to ApproveMAXENJ

mutation ApproveENJ{
CreateEnjinRequest (
identity_id: 1419,
type: APPROVE,
approve_enj_data: {
value: 0
) {

I switched to the mobile wallet instead of the Windows wallet. I was able to approve the Enjin allowance in the REQUESTS section of the wallet upon linking to the identity and getting the default pop-up.

However when trying to CreateEnjinRequest and request a new token, I receive the same error:

“message”: “No records found for Model: EnjinCoin\EnjinOauthClient”,
“code”: 404

This error doesn’t return with all mutation scripts, as I AM able to create Enjin apps from GraphQL.

It seems GraphQL has trouble talking to my wallet, and it has something to do with the Oauth client. Still need help determining what this is please!

SOLUTION: Include the appId argument in the CreateEnjinRequest mutation.

1 Like

Very nice no error any more, but still enj_allowance is still 0! Help! @filip

Using this link worked for me.

1 Like