CODE BLOCKS NOT Working for New Mac

When i begin typing on code blocks this grey box appears. And then when i start typing it increases in size and covers the code I’m writing. Any idea what is going on?

1 Like

Ahhh I have sorted it! If anyone else is having this issue in the future you need to disable “Code Completion” which can be found in the Settings > Editor tab

2 Likes

Hey @ol_frank, hope you are great.

You can also try xcode which is a c++ IDE that is more compatible with macOS than code blocks.

Here you can read more about relative issues like yours and find solutions proposed by our amazing students:

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

3 Likes

Ideal! Thanks you for your informative reply Carlos.
All the best

1 Like