Creating Game & Admin Account - Discussion

Welcome to the discussion thread about this lecture section. Here you can feel free to discuss the topic at hand and ask questions.

@filip
Problem:
In the lecture Installing Wallet Daemon there is a link to the dev portal where we can download the wallet daemon zip file. This zip file is enjin-wallet-daemon-1.0.0-beta.6.zip.
I wasn’t able to create a wallet account with the command node src/main.js account new from this wallet.

Solution:
On this page: https://forum.enjin.io/threads/installing-wallet-daemon.103/ you will find a link to enjin-wallet-daemon-master.zip with which I was able to create a wallet account.

2 Likes

@filip
Problem:
The command mutation createTokenRequest gave me a message error in GraphiQL.

Solution:
When I used the command

mutation ApproveENJ{
  CreateEnjinRequest (
    identity_id: 1,
    type: APPROVE,
    approve_enj_data: {
      value: 0
    }
  ) {
    id,
    encoded_data
  }
}

before the command mutation ApproveMAXENJ, I could then create the tokens with the command mutation createTokenRequest.

1 Like

@filip
Hello,
I had a problem while running the Enjin daemon command: “node src/main.js account new”
It returns “Cannot read property ‘eth’ of undefined
at Wallet.create (/Users/thiagoalmeida/Desktop/enjin-wallet-daemon-1.0.0-beta.6/src/wallet.js:65:37)” and I can’t figure it out by only searching in google. Does anyone had the same problem as I do and know how to fix it?
Thank you so much

1 Like

@sthiagolg
I had the same problem. You will find the solution in my preceding post. You need to download enjin-wallet-daemon-master instead of enjin-wallet-daemon-1.0.0-beta.6. Link in my preceding post.

1 Like

Thanks, you can now find it hosted here as well: https://ivanontech-academy.s3.eu-north-1.amazonaws.com/Enjin-course/enjin-wallet-daemon-master.zip

1 Like

@filip : i have a problem funding my wallet : please the the following message :slight_smile:
Error! Status: 500.
Error broadcasting KETH transaction. Error: Returned error: Insufficient funds. The account you tried to send transaction from does not have enough funds. Required 100630000000000000 and got: 83820429000000000.
ty

@filip : has someone succeeded to have kovan testnet eth withis method ??? or any KENJ ???
i cannot go on without test KENJ… so please explain or please please GIVE ME KENJ ( i have KETH already) :slight_smile:
0x4ab263ca07e5c8b9B70a7E5B9f40523d8b24B458
ty a lot

Thanks @filip, I had the problem, your advise solved my problem, thanks! TY.

The faucet works for me, I just tried it. Are you using this one? https://kovan.faucet.enjin.io/

@filip : the faucet is working now… do not understand… claude_bourgeois had the same problem than me… working and not working after… do not understand anything but ok now… ty filip for your help…

1 Like

Hi filip,
can you please provide the link to the file “how to host your own JSON file” as you’ve said in the lecture?

thanks
daniel

1 Like

@Daniel_Fuchs Thanks a lot for reaching out!
I am the new mentor for Enjin. Can you help me with the video where Filip mentioned about this JSON file?

Regards

1 Like

Hi Taha, it was in the Video “Setting Metadata”: https://academy.ivanontech.com/products/enjin-blockchain-development-101/categories/1684917/posts/5658341

regards daniel

@Daniel_Fuchs
Check this out on “how to host your own JSON file”


Also this is another simpler way of doing it
https://jsonbin.io
2 Likes

Hi @filip
When I am trying to link the account to get the ethereum_address, the node.js src/main.js link XXXXX
gets an error message back:

TypeError: this.account.sign is not a function
at Account.signDummyTransaction (…enjin-wallet-daemon-1.1.0-beta\src\account.js:35:29)
at TrustedPlatform.getAccessToken (…enjin-wallet-daemon-1.1.0-beta\src\trustedplatform.js:213:50)

@Taha I just saw that you’re the new mentor for Enjin. I have trouble with the linking as per my message above. I installed the enjin-wallet-daemon-1.1.0-beta and got the error message.
How can I uninstall that version and get a different version to retry? Or is there an easier resolution to my problem above?

Hello @gabor, hope you are OK.

Taha has been moved into other tasks for now (he is busy with other responsibilities), but he will be back soon.

Now about your wallet issue, you should be able to just delete the daemon wallet folder (all of it) and you will basically uninstalled. Then you should be able to download the last new version from enjin and run it without issues.

Please try that and let me know.

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

1 Like

Hi @thecil Carlos :slight_smile:. Took me a a couple of days, re-installing a few times, looking at different wallet daemons, but finally managed. I guess, that’s how learning happens :laughing:. Finally it works and can continue with the Enjin course. Thank you for your help.

Another comment for the Creating Game item lesson (in case someone is having troubles).
The mutation ApproveMAXENJ didn’t work, only when I changed identity_id to identityId and added the appId (which I had to check from the query)

mutation ApproveMAXENJ{
CreateEnjinRequest (
identityId: xxxx,
appId: xxxx,
type: APPROVE,
approve_enj_data: {
value: -1
}
) {
id,
encoded_data
}
}

same true for the createTokenRequest mutation, requires identityId and appId