DAI Giveaway Code Error

Houston we have a problem. I am trying to run the git hub code on my PC, but it does not work. Anyone has any idea what is wrong? I also noticed the link to the dai-mcd-plugin does not work (maybe that is somehow the issue). Or maybe it is just me doing something wrong? This is the screenshot of me trying to run the code. Thanks for any help.

Best regards,
Z

2 Likes

are you sure you have Nodejs properly installed in the system?
it says:

node_modules missing, did you mean to install?

Try to run it has an administrator.

Also, your running it from “One Drive” folder, are you using this services online? it might have issues if your using a cloud service while trying to run this kind of apps, i suggest to executed locally on your PC.

Meaning, try to execute the Demo from a local folder that is not using any kind of cloud service, it might have issues when modifying some files.

Hello!
So I tried running the code local like you said. But it still does not work. And what did you mean by if I have node.js properly installed (Ivan said just to next everything). Here is a new screenshot. Thanks for your help.

Best regards,
Z

1 Like

Hi guys!

I am having some issue as well.

At first i had the same thing as “zona” shows on the print screen at the previous post.
Then i found that missing file in the “dsr-demo-master”, so copied that, and than came the followings:

Anybody has any idea, would be appreciated!

Thanks,
Andres

@zona & @Andres, i try to run it myself on windows, is not working for me either, i suggest both to read this guide from another student to install a virtual machine and run it on linux.

It work perfect for me in linux days ago, so im encourage both to try it with linux too, this kind of apps are more friendly on linux than windows.

check the guide here: Linux/Unix on Windows system

2 Likes

Hi guys really weird.
I have no issues at this point?
You can also always check out: https://glitch.com/edit/#!/dsr-demo this is basically another container for your app instead of setting it up locally wich always gives issue for some.

This main purpose for the DAI Give away is to see you got the concept, completed the course and most importantly we want to hear your ideas so we can keep on building :smiley:

1 Like

Hi all - no issues here on OsX, fwiw!
Bit of a voyage into https://ohmyz.sh/ recently. Man, I love progress.

I have exactly the same problems as @zona and @Andres .

I am running on linux

This is where it fails

react-scripts start

sh: 1: react-scripts: not found

I solved it by doing the following on linux

It just means something went wrong when dependencies were installed the first time.

I suggest doing these three steps:

  1. npm install -g npm@latest to update npm because it is sometimes buggy.
  2. rm -rf node_modules to remove the existing modules.
  3. npm install to re-install the project dependencies.

Please note I got this from this stackoverflow post

I did have to use sudo before all of the above commands

1 Like

Hi @amadeobrands . I am stuck here as well. I followed all the steps, got the code (dsr demo dile? or some other specific code?), switched my Metamask to Kovan and got testnet eth. As I understand, to run code locally, I should do it on terminal (macos), is it right? Tell me if I am completely stupid somewhere, as I never tried programming, but I am trying my best :slight_smile: I am trying to run the code on different files from what I downloaded, like dsrdemo.js? I see from screenshots, others are using node.js but I have no such file at all. Of course I just get “import command not found”

2 Likes

Awesome :smiley:
It is always so hard to get that right.
That is why I also created https://glitch.com/edit/#!/dsr-demo

Most important is that we get some cool ideas and feedback on the course.

1 Like

If a student has a Windows system, with only the browser as a java interpreter, which are the steps to follow?
I just have to install Node.js or also run a Linux virtual machine?
Thanks

1 Like

FYI I was able to get this working on Win10 a while ago it does work fine on Windows.

Yes you’ll need to install NodeJS (https://nodejs.org/). If you have trouble you may need to use an earlier version. I can verify that 10.18.0 works fine. This was the version I had been running during the Smart Contract 101 course.

1 Like

I tried
installing the latest version of Node.js and chocolatey updated all too. See:

In the Windows 10 command prompt window:
runned npm install but got many errors: https://i.gyazo.com/ff45d9d939a88a7057eb6448b1e76661.png
runned npm start with other errors
https://i.gyazo.com/a67d244a65bb1091d80c7b003b8e676f.png

Do you think it all depends on the Node.js version? if yes how can I downgrade?
Many thanks!

1 Like
I can't run the DAI Savings Rate demo neither locally, neither on Glitch. All the embedded projects on Glitch show me "This site can’t be reached" 
Unfortunately I'm stuck at this final step of the course since 2 days.

Today Glitch has no glitches anymore :slight_smile:
so I followed the steps
https://gyazo.com/74e7ae5c5ba0a1b58ad2b847604d06ba
https://gyazo.com/a8c798ec0c981378d4b60ab077f059a2
https://gyazo.com/2c7e27daf0b58bd67b55622552d6d5a4
https://gyazo.com/db4a23ae219a5b5acc574494a809f1fc
https://gyazo.com/658c5dcdf08f7732655781795c67885e

1 Like

Looks like you got it working. Gratz!

2 Likes

Hey.
I am a user who had also problems with installing the demo. I am using Win10. NodeJs was installed correctly, but I was not able to install the code (not with yarn or npm). When you are in your PowerShell type in the command line npm outdated. There I got the information that whole things from the Dai.js (MakerDao) are missing. Then I found out in order to install the package I need Git. You can download it here:
https://git-scm.com/download/win
With the command git --version you can check whether git is installed or not. When you have installed Git, you can install everything as it is describe in the readme file from Amadeo. (just type yarn install).
For starting the demo, just use yarn start.
In Short, if you have not installed Git, you have to do it. Once you have installed Git, you can install and start the demo.

1 Like