Deploying to Testnet - Discussion

Hi @Pellerin
I also had issues with metamask this days, reloading remix and logout login from metamask helps to solve it :frowning:

1 Like

I set the ENVIRONMENT to Injected Web3 but a connection is not made to MetaMask/Ropsten Test Network ::

1 Like

Hi @JesusIsLord
Did you try to refresh the remix page ? Which browser are you using ?

1 Like

Hello, Gabba - I refreshed the page (CHROME) and connected to MetaMask and completed the task. Thanks …

1 Like

Thank you Philip and Ivan for making this course! One day I was downtown and I got stopped by a guy who asked me to write on a big board what my dream was. I wrote solidity because I wanted to learn it after starting in the academy and after having a lot of bad experiences with 3rd parties in general in society. Great course!

2 Likes

@gabba Your link saved me some headaches, too. Thanks!

2 Likes

@filip Thank you so much for this amazing course! I would really love to do a project on my own now, but I can’t think of anything that may be suitable at my current level of expertise. Any recommendations?

1 Like

@Filip

I’m not sure what all is going on.

The gas link you shared went to a non-existent page, so I waybacked and got it.
:expressionless: Interesting.

Also,
I couldn’t get my external contract to interact with HelloWorld even after I copy/pasted your code. I think it’s a Remix issue. All morning long has been calling HelloWorld undeployable because it’s “abstract”, roughly 3 out of 4 times, then when it did deploy it called errors that I wasn’t submitting eth, which I was, when I was trying to create a person…
This same error occurred both in External and in HelloWorld.

I got HelloWorld happy again, but still no External cooperation.

Hoping it works on MetaMask.

Hi @petra

In remix you have to select the version of the compiler before compiling the smart contract, i think your error come from this.
Try to use the same version as the one at the tope of your solidity contract

Hi @gabba and @filip ,

I am having the same issue as @petra. I thought it may have been an error related to my code, so I used the code that was provided in Github. However, there is no external cooperation either for me. Im guessing there is an issue with Remix? If you have any other solutions in mind, please let me know.

I also ran into another problem. I tried transferring 1 Eth from the Ropsten Ethereum Faucet. The block has been pending for a while, but in the video it went through very quickly. Does anyone have any ideas on how to fix this?

Thank you!

This is the error I get @filip

transact to ExternalContract.externalCreatePerson errored: VM error: revert.
revert The transaction has been reverted to the initial state.
Note: The called function should be payable if you send value and the value you send should be less than your current balance. Debug the transaction to get more information.

Hi @filip,
I cannot switch to injected web3 on remix, it is stating I do not have a web3 provider. I do have metamask installed on my bravo browser however.

Hi @chaneltiana

EDIT: Make sure you have selected the right contract in the contract windows, you need to deploy HelloWorld, not the abstract contract

Use to link to get eth from the testnet
https://faucet.ropsten.be/

Is your createPerson method have the keyword payable ?

function createPerson(string memory name, uint age, uint height) public payable costs(1 ether)

Did you send 1 ETH or more when you are calling this method ?

Did you change you Environment to “Inject Web3” ?

Do you have ETh on your metamask account ?

I tried and it’s still working so the issue come from your remix configuration.

What do you mean ?
The “abstract” error sent by the compiler is caused by a modification between solidity 0.5.X and 0.6.X
So as i said to petra you should check that you are using the compiler version 0.5.12

1 Like

Hi @mjwatson10

Are you logged in Metamask, did you selected the ropsten testnet ?
If so, try to refresh the remix page when the “Injected Web3” is selected in your environment, there is issue sometime with remix when switching from an Environment to an other.

1 Like

Thanks for the help, I was actually able to fix it. I guess my brave browser had a pop up blocker so I just disabled it and I was able to link to my metamask

1 Like

https://faucet.metamask.io/ and https://faucet.ropsten.be/ were not working for me. I finally got my Ropsten network ETH from this faucet: https://teth.bitaps.com/

2 Likes

Hello @filip,

Received the following error message from https://faucet.metamask.io/ - Please help!

{“error”:"[ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“message”:“Too Many Requests”,“data”:{“originalError”:{}},“stack”:“Error: Too Many Requests\n at eval (/www/node_modules/web3-provider-engine/subproviders/rpc.js:52:23)\n at Proxy.eval (/www/node_modules/web3-provider-engine/subproviders/rpc.js:54:11)\n at Object.eval [as apply] (LavaMoat/core/kernel:806:17)\n at Object.eval [as apply] (LavaMoat/core/kernel:806:17)\n at Request.self.callback (/www/node_modules/request/request.js:186:22)\n at Object.eval [as apply] (LavaMoat/core/kernel:806:17)\n at Proxy.emit (events.js:310:20)\n at Object.eval [as apply] (LavaMoat/core/kernel:806:17)\n at Request.eval (/www/node_modules/request/request.js:1155:10)\n at Object.eval [as apply] (LavaMoat/core/kernel:806:17)”}}’"}

Hello @filip,

Tried https://ropsten.etherscan.io/ but did not work either - any suggestions?

Sometime the faucet wont work, as it has a daily limit. The error messages can be a bit confusing at times though.

Can you try if https://teth.bitaps.com/ works (as mentioned by dAnijboned)? I just checked it and that one seems to work (make sure you’re on the Ropsten test network). Otherwise, can you send your address? I can transfer a test eth.

1 Like

Ok thanks Erno - will try it - Just tried https://faucet.dimensions.network/ and waiting for confirmation

1 Like