Getting a 404 error for Metamask


I’m working on the first dapp lesson and when I try to load the project on localhost:8000, I get a 404 error in the console:

“DevTools failed to load SourceMap: Could not load content for chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/sourcemaps/ HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME”

Could somebody tell me what I’m doing wrong? Thank you.
Here’s a repo, the Helloworld folder contains the Truffle project for migrating and the Dapp folder has main.js and the files for the browser UI:

Hey @mburtonshaw

I cloned your project and I am able to use it.
Are you running a Python server?

Navigate into the folder called dapp and run python -m SimpleHTTPServer

Then go to localhost:8000

Happy learning,

1 Like

@dan-i Hello,
yes I am running a python server when this happens. I just tried to re launch it and I’m getting the same issue. That said, I also noticed that I get the same error on the forum website. Could there be a problem with my MetaMask itself?

Also, I now have a console.log() function set for before and after a transaction; when I run everything I get the before message but not the after message. And my MetaMask shows no transactions for any of the accounts there.

I have another question that is probably related to this. Whenever I execute “migrate --reset” in truffle it changes my contract address. So do I have to update that address in the contract instance in main.js every time as well?