NodeJS Install problems

Hi all. In the Lecture “Windows Installation & Demonstration” Ivan installs NodeJS. He creates a folder on his HD and drags that to the text after cd. I go to do the same thing and this allert appears on my screen

Has anyone had this same problem before and know how to fix it? Is there some sort of Access password on my machine that i dont know how to fix?

Urgent help needed.

Thanks x

Have you tried to open powershell has Administrator?

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

1 Like

Hi @thecil (Carlos), So ive been camping with the kids and been away for a night. I have ran it as Admin and the error doesnt come up. But when i drag the file no address gets added to the syntax?

Not sure why i can access the file on Powershell.


thats good, means that you need to run the powershell has admin.

Could you please be more detailed? share me some code or screenshots please, so i can understand better how to help you.

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

no worries mate. I ran Powershell normally and an error appeared. then i ran it as an admin and no folder address apears after ‘cd’ when i drag it. Its like it doesnt read it.

Here is a screen shot.


when i do it the folder address does not appear when i drag.

Let me know if you need anything else.

Ok, you have to move yourself through the terminal to reach your folder.

Commands to use on PowerShell

  • cd .. :go to last folder on the route. EX: C:/FOLDER1/SUBFOLDER, after cd .. command you will be in C:/FOLDER1
  • dir : will show you a list of folders that exist on your route.
  • cd folderName go into that folder.

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

i tried typting those commands in and was getting errors. Then i played about with \ and typing the route in… Not sure that is what you are trying to show me.

When im running Powershell not as an Admin i get route starting with Home. When i run as admin i get System32 …

I see your cd command already worked @Rob_McCourt.

Let’s go through all the commands you tried in the screenshot.

1st one – just typing cd won’t help with anything. The syntax is “cd” then “path of folder”. Ex - “cd C:\users\Malik

2nd one – The second command gave you an error because it just couldn’t find that path. There is no issue with the syntax here.

3rd one – Worked perfectly! as you can see, your directory changed. It went from “C:\WINDOWS\system32” to "C:\users\Home\Documents\node ja demo". This means you are now in the “node ja demo” folder

4th one – Here the syntax is wrong. After “cd + path of the folder”, giving a “dir” command is incorrect. Thus, you received an error.

Now, coming to your initial issue. There are some terminal versions where dragging and dropping won’t copy it’s path automatically. Perhaps that might be your case. So instead of dragging and dropping, we just type out the entire path manually. That is what Carlos had advised you to do.

hOpe this clears it out.

Happy Learning! :slight_smile:


wicked. The point of the exercise i suppose is to get in to that folder by pointing the terminal to the address. Thats cool i can live with that for now.

Cheers buddy. You both have been a great help. Pints are on me !!!


1 Like

hi mate, just to let you know ive sorted that issue. I was using another version of Powershell ICE. Ive found the program that is just powershell and everything is working great now.

Thanks @Malik

1 Like